Un mal día Geek


Como habrán podido apreciar ya hace unos días que no actualizaba el blog, sin embargo tengo una historia que contarles, una epopeya de sangre, frustración y triunfo. Todo empezó aquel miércoles 22 de julio cuando me disponía a instalar Fedora, jamás había usado el entorno KDE ni tampoco un sistema basado en redhat; No sé si fue el aburrimiento o la simple curiosidad la que me llevo por ese sendero tan incierto. Primero la instalación: Fue más que rápida, en menos de 15 minutos ya tenía arrancando mi sistema, después de ello jamás conté con toparme con una actualización tan absurda, tomo 2 porcinas horas en terminar de actualizarse, tomando en cuenta que es una distribución relativamente nueva, tenía bastante que corregir.

Segundo, el entorno KDE: Inmediatamente que acabo la actualización reinicie esperanzado en empezar a pimpear mi sistema, siempre había sido un usuario gnome, había incluso probado otros entornos como Xfce (bastantes sencillos por cierto) y no había tenido un solo problema. No podía encontrarme en KDE, el wallet me pedía guardara cada una de mis contraseñas (Ja!) como si usara solo 3 o 4 para tener que ser molestado por esa aplicación (al menos una vez) cada que tuviera que entrar a alguna cuenta.

Al poco tiempo me di cuenta que faltaba algo básico para mi, el sonido… Tenía todo bien configurado y solo lograba hacer que se escuchara a manera de test, busque y busque por la red de redes sin encontrar una respuesta adecuada, había problemas similares pero ninguno que resolviera el mio. Decidí continuar revisando la distro hasta que terminé por convencerme que no era lo mio, era hora de instalar Linux Mint!

Una vez quemado mi disco de Linux Mint 7 (pasada una travesia ya que fedora no reconocia mis lectores por mas paquetes extra que instalara) me di cuenta que era una distro bastante rápida, con una apariencia menos robusta que Ubuntu y una que otra novedad y paquetes ya pre-instalados, deje mi sistema como dios manda y todo era miel sobre hojuelas.

Mientras revisaba la versión de mi kernel, me di cuenta que sería buena idea actualizarlo, compile, instale, reinicie y ahí tenía mi nuevo kernel, elimine el viejo y disfrutaba de los beneficios de un PC bien actualizado, cuando derrepente al estar escuchando una de mis canciones favoritas… bah! que se va el puto sonido!!! Maldita sea no puede ser!!! (como diria javier alarcon en el partido de México vs P. Rico).

Respire, miré la configuración de pulseaudio, todo normal, el resto de aplicaciones y todo bien. ¿Que put4$ será? me pregunte, empece a buscar por todas las webs en vista de soluciones, al parecer era un bug o una incompatibilidad de ALSA, intente de todo, compilar de nuevo los drivers de alsa, instalar uno por uno las librerias de pulseaudio en busca del problema y nada. Decidí que quizá había sido por el kernel, así que sin más remedio pasé a formatear e instalar de nuevo mi sistema. Ahora desde el principio sin audio… hice algunos de los pasos que se mostraban en una web, logre tener audio por unos instantes (sin poder tener audio de dos instancias distintas al mismo tiempo).

Reinicie y fue como si un enano colgara de mis cojones… SIN AUDIO DE NUEVO!!! L-a p-u-t-a q-u-e l-o-s p-a-r-i-o. De nuevo tome un profundo respiro y formatee, paso exactamente lo mismo al formatear e instalar todo otra vez. En mi desesperación decidí por ahí de las 11 p.m. que el buen jaunty no podría fallarme, después de todo era el único que hasta en el live cd tenía sonido, procedi a instalar el sistema, luego las actualizaciones y al reiniciar oh sorpresa. Creí que había sido mi mal karma por haberme burlado de todos aquellos usuarios de windows, ahora el cruel destino me había privado de la música… en mi desesperación estuve a punto de tomar un CD de un windows desatendido que tenía por allí, lo pensé, sabía que neceistaba un descanso y de paso hablarle a mi novia.

Mientras platicaba con ella me preguntó que había estado haciendo todo el santo día y le respondí que estuve desde la mañana con problemas en mi máquina y haciendo ejercicio para sacar la ira, me regaño (aun que ella diga que no) por moverle «a lo que no le se». Esas palabras en lugar de desanimarme me dieron la fuerza para dar un intento más (después de todo tengo una obsesión tipo sheldon cooper) cuando terminé de hablar con ella quite Ubuntu, tome mi disco de Linux Mint, me encomendé a Linux Torvalds. Una vez más todo el procedimiento estaba hecho, el resultado: Seguía sin sonido.

Con más calma recordé que tengo dos tarjetas de audio (la integrada a la mother board y una PCI) ambas estaban reconocidas, pero por alguna razón solo funcionaba correctamente la del PCI, pulseaudio y ALSA daban prioridad a la otra, no logre que mi tarjeta estuviera seleccionada por default sin crear algun conflicto. Reinicie una vez más, entre al BIOS y desactive el sonido del motherboard. Entre a linux mint, instale y compile de nuevo los drivers de ALSA y pulseaudio, seguí un par de indicaciones extras que encontre en un blog.

Volví a encender mi máquina y ahí estaba el bendito sonido (incluso escuchaba dos películas en dos reproductores distintos) los videos de youtube, todo por fin funcionaba. Eran las 6:00 a.m. hice todo tipo de pruebas para cerciorarme que no volviera a fallar y en efecto, aquí me tienen escribiendo esta anectoda mientras escucho a Cocky Brain Fuzz, vencí al monstruo. De paso les dejo una captura de pantalla y después les pondré las soluciones por si esto les llega a pasar en un futuro 😀


Esta entrada fue publicada en Geek. Guarda el enlace permanente.

15 respuestas a Un mal día Geek

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *